Saturday, January 24, 2009

fans still running after stand by

Ever been annoyed by the fact that you wanted to put your desktop computer to stand by mode and the fans kept running over and over?
I will first explain how the issue evolved over time in my case.
If you are inpacient you may skip to the solution.

Then:
Just after installing my new desktop computer with Windows XP SP1 (a few years ago) I wanted to be able to press the Sleep button on my keyboard and suspend my desktop to memory so it wouldn't consume much energy, nor make noise but to be able to resume in a few secs.
After setting the correct BIOS setting, pressing the Sleep button (or choosing the stand-by option in the) put the OS in stand-by (the power led was blinking), but the fans continued to run endlessly! Not so good, as I didn't fully accomplish all my three goals: I was able to resume very fast, but the noise was the same as the computer was running and the power consumption was not at it's minimum.
After googling/livesearchin' a bit, I managed to achieve all three goals. Curious how?

Today:
Everything went as I wanted with my stand by issue until yesterday when the fans became stubborn again and kept running after going to Stand By mode. That annoyed me once again :-) and for a second a "quick" solution hit my head: "yeah, I know, i should reinstall Windows anyway..". Of course, the rational part of me quickly rejected that stupid solution and decided: I should solve this the elegant way and also tell others how to do it.
So I tried to remember what I did back then and also what I changed these days in the system that could cause the stubborn fans problem. I keep forgetting uninteresting stuff (like having an important official meeting next day) so I didn't remember how I solved it a few years ago, but I realized that I changed the Power scheme a few days ago so my desktop would hibernate automatically after 3 hours of idle time.

So I went  back to Control Panel -> Power Options to find out that the Home/Office Desk scheme was active. Changed that to some other scheme, set the desired thresholds, hit OK, and then the Sleep button on my keyboard.
Voila! the fans did go off 5 secs after the hard disk.
Issue solved!
So please make sure you are not using the Home/Office Desk theme if you don't want to hear the fans in Stand By mode.